Jump to content
Support Board

User Browser In Online Lists


Adriano
 Share

Recommended Posts

  • Administrator

User Browser In Online Lists


This plugin will detect the user's browser and will display the icon next to their name in Who's Online and Recently Browing widgets.

Settings:

  • Hide browser icon on Desktop
  • Hide browser icon on Phones
  • Hide browser icon on Tablets
  • Show User Agent details (will display browser name and operating systems)
  • Icon size
  • Display browser icon to (groups to choose)

Note:


 

Link to comment
Share on other sites

  • 1 month later...
  • Administrator

Replying to your question, Opera image isn't available. You can see it on  Account Settings -> Recently Used Devices:

Capturar.PNG

The plugin is working as expected as it shows exactly what the device is:

Capturar.PNG

I'll see with IPS why Opera doesn't show the image: https://invisioncommunity.com/forums/topic/455452-opera-image-isnt-showing-up-on-recently-used-devices/

Link to comment
Share on other sites

  • Administrator
14 minutes ago, Vincenzo said:

Thanks a lot.

Question: where can I insert that code that Mark Round suggested, to temporarily fix the bug waiting for IPS 4.5?

https://invisioncommunity.com/forums/topic/455452-opera-image-isnt-showing-up-on-recently-used-devices/?do=findComment&comment=2809426

If you want to fix in MY plugin, go to applications/core/interface/logos/browsers and rename Opera.png to Opera Next.png:

Capturar.PNG

It remain broken on Account Settings.

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
  • Administrator
14 hours ago, Vincenzo said:

Hi Adriano, the same problem that was present with Opera, now I see it with Android Browser.
Is this also true for you?

2020-02-06-231753.png

Is this a mobile device ? If it is, I can't test as I don't use Android.

  • Like 1
Link to comment
Share on other sites

3 hours ago, Adriano said:

Is this a mobile device ? If it is, I can't test as I don't use Android.

I ask the user and then I'll let you know, because I don't know 😉

Link to comment
Share on other sites

Hi, I show you the tests made with the Chrome Browser ...


This is what I see on the icon before the change

d.png

 

This is what appears in Chrome if I open "Inspect"

a.png

 

After removing %20 from the png name, the icon appears

b.png

 

Result in the list of online users after the change in Chrome test

c.png

 

I tried to rename the icon, removing the characters "%20" as in the test performed in Chrome but it did not work equally.
Do you have any suggestions for me?

 

Link to comment
Share on other sites

  • Administrator
13 hours ago, Vincenzo said:

After removing %20 from the png name, the icon appears

Same problem of the Opera. That's not a problem in my resource. IPS is detecting wrong. The image doesn't has spaces:

Capturar.PNG

 

So edit the name of the image via FTP to add the space.

Link to comment
Share on other sites

1 minute ago, Adriano said:

Same problem of the Opera. That's not a problem in my resource. IPS is detecting wrong.

Do you have a temporary solution to suggest to me as you did with Opera?

Link to comment
Share on other sites

Hi, if it can be useful as information, I just did a test with the new Opera GX Browser (which the plugin reads like Opera Next, but it doesn't matter)
 

W.png

 

The icon does not appear, but if I add the space (as you suggested to me in a similar episode a few days ago) everything works

WW.png

 

https://invisioncommunity.com/forums/topic/455452-opera-image-isnt-showing-up-on-recently-used-devices/?do=findComment&comment=2811187

From what I read in your topic with IPS on Opera, the reason for this is due to the fate that I have not yet updated to 4.4.10? They are currently still on 4.4.9.2
Do you think that's the cause?

Link to comment
Share on other sites

 Share

×
  • You have 0 invitations left

    Latest Invitations

    1. There are no invited members to display
×
  • Create New...